Skip to main content

December 23 java coding question PRA solution

23 dec pra java coding question solution.

Question:

Create the class Student with below attributes.

id-int

name-String

marks-int

age-int


write getters and setters and parametrized constructor in Student class.


Create class Solution with main method.


implement 2 static methods-findStudentWithMaximumAge and searchStudentById

in Solution class.


findStudentWithMaximumAge method:

    This method will take the Array of the Students objects as input and 

returns the Student object having maximum Age.

  For this method,the main method should print the student object details

with maximum age as it is.   



searchStudentById method:

    This method will take 2 input parameters.Array of the Students objects

and an int value  id.and returns the Student object having the mentioned id 

if found, else return null if not found.

  For this method ,main method should print the details of Student objects 

as it is,if the returned value is not null. or it should print 

"No Student found with mentioned attribute." if the returned value is null.


These 2 methods should be called from main method.

*************************************************************************************************

sample input1:

4

100

jisha

35

23

104

Uma

30

45

105

Eva 

36

21

102

Cissy

24

51

100



Sample output1:

id-102

name-Cissy

marks-24

age-51

id-100

name-jisha

marks-35

age-23



**************************************************************************************************

code:


package Dec23;

import java.util.Scanner;


public class Solution {

    public static void main(String[] args) {

        Student[] students=new Student[4];

        Scanner sc=new Scanner(System.in);

        int in=sc.nextInt();sc.nextLine();

        for (int i = 0; i <in ; i++) {

           int a=sc.nextInt(); sc.nextLine();

           String b=sc.nextLine();

           int c=sc.nextInt();sc.nextLine();

           int d=sc.nextInt();sc.nextLine();

           students[i]  = new Student(a,b,c,d);

        }

        int input1=sc.nextInt();sc.nextLine();

        Student ans1=findStudentWithMaximumAge(students);

        System.out.println("id-"+ans1.id);

        System.out.println("name-"+ans1.name);

        System.out.println("marks-"+ans1.getMarks());

        System.out.println("age-"+ans1.getAge());



        Student ans2=searchStudentById(students,input1);

        if(ans2==null)

        {

            System.out.println("No Student found with mentioned attribute.");

        }

        else

        {

            System.out.println("id-"+ans2.id);

            System.out.println("name-"+ans2.name);

            System.out.println("marks-"+ans2.getMarks());

            System.out.println("age-"+ans2.getAge());


        }


    }

    

   public static Student findStudentWithMaximumAge(Student[] students)

    {

        int max=students[0].age;


        for (int i = 1; i <students.length ; i++) {

             if(students[i].age>max)

             {

                 max=students[i].age;

             }

        }

        for (int i = 0; i <students.length ; i++) {

            if(students[i].age==max)

            {

                return students[i];

            }

        }

        return null;

    }

     public  static  Student searchStudentById(Student[] students,int input1)

    {

        for (int i = 0; i <students.length ; i++) {

            if(students[i].id==input1)

            {

                return students[i];

            }

        }

        

        

     

         return null;

    }

}


class Student

{

    int id;

    String name;

    int marks;

    int age;


    //parametrized constructor



    public Student(int id, String name, int marks, int age) {

        this.id = id;

        this.name = name;

        this.marks = marks;

        this.age = age;

    }


    //getters and setters



    public int getId() {

        return id;

    }


    public void setId(int id) {

        this.id = id;

    }


    public String getName() {

        return name;

    }


    public void setName(String name) {

        this.name = name;

    }


    public int getMarks() {

        return marks;

    }


    public void setMarks(int marks) {

        this.marks = marks;

    }


    public int getAge() {

        return age;

    }


    public void setAge(int age) {

        this.age = age;

    }

}


****************************************************************************************************

Didn't understand the Solution given above?

Watch the video given below.






****************************************************************************************************

Comments

Popular posts from this blog

Travel_Agencies

  Problem Statement Create a class TravelAgencies with below attributes: regNo – int agencyName – String pakageType – String price – int flightFacility – boolean Write getters, setters for the above attributes . Create constructor which takes parameter in the above sequence. Create class Solution with main method. Implement two static methods – findAgencyWithHighestPackagePrice and agencyDetailsforGivenIdAndType in Solution class. findAgencyWithHighestPackagePrice method: This method will take array of TravelAgencies objects as an input parameter and return the highest package price from the given array of objects. agencyDetailsForGivenldAndType method: This method will take three input parameters -array of TravelAgencies objects, int parameter regNo and String parameter packageType. The method will return the TravelAgencies object based on below conditions. FlightFacility should be available. The input parameters(regNo and packageType) should matched with the regNo

TCS XPLORE CAMERA PROCTORED ASSESSMENT EXAM JAVA CODING SOLUTION 10 MAY,2021. FOOTWEAR PROBLEM.

 create a class Footwear which consists of the below attributes.   footwearId=int   footwearName=String   footwearType=String   price =int the above attributes should be private. write getter and setter and parametrised constructor as required. create the class footwearProgrammm with the main method. implement the 2 static methods.getCountByType and getSecondHighestPriceByBrand in the Solution class. getCountByType method:    this method will take two input parameters. array of the Footwear objects and string parameter footwear type. this method will return the count of the footwears from array of the footwear objects for the given type of footwear. if no footwear with the given footwear type is found in the array of footwear abjects,then the method should return 0. getSecondHighestPriceByBrand method:   this method will take 2 input parameters-array of footwear objects and string parameter inputFootwearName.the method will return the second highest footwear objects based on the price