23 dec pra java coding question solution.
Question:
Create the class Student with below attributes.
id-int
name-String
marks-int
age-int
write getters and setters and parametrized constructor in Student class.
Create class Solution with main method.
implement 2 static methods-findStudentWithMaximumAge and searchStudentById
in Solution class.
findStudentWithMaximumAge method:
This method will take the Array of the Students objects as input and
returns the Student object having maximum Age.
For this method,the main method should print the student object details
with maximum age as it is.
searchStudentById method:
This method will take 2 input parameters.Array of the Students objects
and an int value id.and returns the Student object having the mentioned id
if found, else return null if not found.
For this method ,main method should print the details of Student objects
as it is,if the returned value is not null. or it should print
"No Student found with mentioned attribute." if the returned value is null.
These 2 methods should be called from main method.
*************************************************************************************************
sample input1:
4
100
jisha
35
23
104
Uma
30
45
105
Eva
36
21
102
Cissy
24
51
100
Sample output1:
id-102
name-Cissy
marks-24
age-51
id-100
name-jisha
marks-35
age-23
**************************************************************************************************
code:
package Dec23;
import java.util.Scanner;
public class Solution {
public static void main(String[] args) {
Student[] students=new Student[4];
Scanner sc=new Scanner(System.in);
int in=sc.nextInt();sc.nextLine();
for (int i = 0; i <in ; i++) {
int a=sc.nextInt(); sc.nextLine();
String b=sc.nextLine();
int c=sc.nextInt();sc.nextLine();
int d=sc.nextInt();sc.nextLine();
students[i] = new Student(a,b,c,d);
}
int input1=sc.nextInt();sc.nextLine();
Student ans1=findStudentWithMaximumAge(students);
System.out.println("id-"+ans1.id);
System.out.println("name-"+ans1.name);
System.out.println("marks-"+ans1.getMarks());
System.out.println("age-"+ans1.getAge());
Student ans2=searchStudentById(students,input1);
if(ans2==null)
{
System.out.println("No Student found with mentioned attribute.");
}
else
{
System.out.println("id-"+ans2.id);
System.out.println("name-"+ans2.name);
System.out.println("marks-"+ans2.getMarks());
System.out.println("age-"+ans2.getAge());
}
}
public static Student findStudentWithMaximumAge(Student[] students)
{
int max=students[0].age;
for (int i = 1; i <students.length ; i++) {
if(students[i].age>max)
{
max=students[i].age;
}
}
for (int i = 0; i <students.length ; i++) {
if(students[i].age==max)
{
return students[i];
}
}
return null;
}
public static Student searchStudentById(Student[] students,int input1)
{
for (int i = 0; i <students.length ; i++) {
if(students[i].id==input1)
{
return students[i];
}
}
return null;
}
}
class Student
{
int id;
String name;
int marks;
int age;
//parametrized constructor
public Student(int id, String name, int marks, int age) {
this.id = id;
this.name = name;
this.marks = marks;
this.age = age;
}
//getters and setters
public int getId() {
return id;
}
public void setId(int id) {
this.id = id;
}
public String getName() {
return name;
}
public void setName(String name) {
this.name = name;
}
public int getMarks() {
return marks;
}
public void setMarks(int marks) {
this.marks = marks;
}
public int getAge() {
return age;
}
public void setAge(int age) {
this.age = age;
}
}
****************************************************************************************************
Didn't understand the Solution given above?
Watch the video given below.
****************************************************************************************************
Comments
Post a Comment